每日一折腾—升级 PHP5.6.11

今天又手贱,看到 PHP7 Beta 版发布了,但是 lnmp 暂时不支持升级,于是就想着升级到 5.6.11 也好,修正一些漏洞和 bug,结果却一直安装不了。

仔细看了 log 文件,发现是有个错误提示,Google 了一下,发现以下解决办法(PHP 编译 configure 常见错误总结):

Configure: error: Please reinstall the libcurl distribution – easy.h should be in /include/curl/
centos: yum install curl curl-devel (For Redhat & Fedora)
# install libcurl4-gnutls-dev (For Ubuntu)

然后就 OK 了,顺便吐槽一下中华电信处理工单的速度真的很慢。

Leave a Comment

This site uses Akismet to reduce spam. Learn how your comment data is processed.